[Webkit-unassigned] [Bug 27952] cssgrammar.cpp fails to compile with RVCT compiler
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Aug 4 10:24:43 PDT 2009
https://bugs.webkit.org/show_bug.cgi?id=27952
Darin Adler <darin at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Status|UNCONFIRMED |NEW
CC| |darin at apple.com
Platform|PC |All
AssignedTo|webkit-unassigned at lists.web |laszlo.1.gombos at nokia.com
|kit.org |
Ever Confirmed|0 |1
--- Comment #3 from Darin Adler <darin at apple.com> 2009-08-04 10:24:42 PDT ---
(In reply to comment #2)
> (From update of attachment 34033 [details])
> This is going to copy the string. that's an extra malloc during parsing, and
> likely a slowdown. :(
The old code already copies the string. This is bad. The best fix that fixes
both compiling and improves performance is to create a
charactersEqualIgnoringCase function that works with a character pointer and
length. This would be like the other "characters" functions in
PlatformString.h.
We could also overload equalIgnoringCase for CSSParserString; that would just
be a convenience that would make it slightly easier to read.
Code to do this is already present in StringImpl.cpp; it should be relatively
straightforward to refactor it.
In the mean time I actually see nothing wrong with Laszlo's initial patch,
except that there is a stray space after "selector". But I'd love it if we
could get rid of the stray memory allocation here.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list