[Webkit-unassigned] [Bug 25419] InspectorController refactoring proposal

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 30 09:19:22 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=25419





------- Comment #5 from pfeldman at chromium.org  2009-04-30 09:19 PDT -------
(In reply to comment #4)
> I think a good approach would be to do step 1 (and maybe 2) now using the
> existing direct JS call approach. That way we know how well it works early on.
> 
> Basically I think we should do each separable step in stages and land them.
> 
> It would also be best to have separate patches for JSON with standalone tests.
> But maybe bug 20031 will give us the right JSON code.
> 
> Over all I think the proposal makes sense.
> 

Ok, sure, let us start with step 1 and see how it goes. Actually, step 2
without migrating to Values is pretty much a noop. It would be great if 20031
addressed it, but as I understand, it is going to be resolved in JSC terms.
Hence we would still need to find a platform (JS core)-independent
serialization engine.

We could try doing it from within JS: InspectorController receives a network
event (didReceiveResponse), it passes it into javascript for serialization by
means of Scrip* objects, javascript code serializes message. Quite an
indirection, but no code duplication in the JSON serialization area. Also could
have some performance implications. Do you think it is better than pulling
Value/JSONReader/JSONWriter in? I think I can run some experiments on it.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list