[Webkit-unassigned] [Bug 25030] Need to refactor MessagePort to support multi-process implementations

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 6 03:55:21 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=25030


ap at webkit.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #29241|review?                     |review-
               Flag|                            |




------- Comment #3 from ap at webkit.org  2009-04-06 03:55 PDT -------
(From update of attachment 29241)
> +        * dom/RemotePort.h: Added.
> +        (WebCore::RemotePort::~RemotePort):

RemotePort doesn't look like a great name to me - first, it doesn't say that
it's all about MessagePorts, and then, it's not clear in which sense it is
"remote". Other similar interfaces have the word Proxy in them, maybe
MessagePortProxy would fit better?

> +    m_entangledPort->deliverRemoteMessage(message, newMessagePort);

Again, a naming nitpick. Are there any non-remote messages? This function name
makes it look like there are.

> +        virtual void deliverRemoteMessage(const String& message, PassRefPtr<MessagePort>) = 0;

There is no need to include PlatformString.h just for this, a forward
declaration would suffice.

These are all nitpicks, but the patch mostly does renaming, so I think it's
fair to be picky about names.

Besides renaming, there are changes to how entangling is implemented, it would
be nice to provide a rationale in the ChangeLog.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list