[Webkit-unassigned] [Bug 24988] The Webkit plugin mime type matching code should allow the wildcards

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 2 10:32:08 PDT 2009


https://bugs.webkit.org/show_bug.cgi?id=24988





------- Comment #4 from darin at apple.com  2009-04-02 10:32 PDT -------
(From update of attachment 29194)
> -bool PluginData::supportsMimeType(const String& mimeType) const
> +bool PluginData::supportsMimeType(const String& mimeType, bool allowWildCard) const

I suggest two separate functions rather than adding a boolean argument to this
function. The boolean is extremely unclear at the call site. You see a "false"
or "true" and have no idea what it means, requiring a comment at the call site.
Instead the version that doesn't allow wild cards could be named
supportsMimeTypeWithoutConsideringWildCards, perhaps.

Other aspects of this patch look good.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list