[Webkit-unassigned] [Bug 20949] Catch repeated messages in Inspector Controller to limit memory usage

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 22 14:37:08 PDT 2008


https://bugs.webkit.org/show_bug.cgi?id=20949


timothy at hatcher.name changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #23668|review+                     |review-
               Flag|                            |




------- Comment #8 from timothy at hatcher.name  2008-09-22 14:37 PDT -------
(From update of attachment 23668)
+            var previousMessageElement = this.currentGroup.messagesElement;
+           
previousMessageElement.removeChild(previousMessageElement.lastChild);
+            previousMessageElement.appendChild(msg.toMessageElement());

previousMessageElement is not the right name for that variable, messagesElement
is a better name.

+            msg.repeatCount -= this.previousMessage.repeatCount;

This line deserves a comment.

Even better would be to assign the difference of the repeat count to a new
property on the msg, so clients know they are getting the difference. Better
yet, just store it in a loval variable, and pass that number to
addMessageToResource. In addMessageToResource if the number is > 0 then do the
repeat path.

-            msg.resource = WebInspector.resourceURLMap[msg.url];
+            msg.resource = WebInspector.resourceURLMap[msg.url]; 

Don't land the extra space at the end of that line.

r- until some of these are fixed.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list