[Webkit-unassigned] [Bug 20422] Patch to allow custom memory allocation control

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Sep 21 14:28:03 PDT 2008


------- Comment #13 from darin at apple.com  2008-09-21 14:28 PDT -------
(In reply to comment #10)
> we would gladly
> help to replace all new and delete operators to the new ones.

I believe the proposal is this:

    1) Add AllocBase (looking for better name) as a base class for every class
we new/delete or one of its base classes.
    2) For objects we new/delete that are not classes that can be changed to
derive from AllocBase, use newObject/deleteObject and newArray/deleteArray.

One trick is coming up with a good technique for making sure we do this and
catch mistakes either at compile time or at least at runtime if we do it wrong.
It's going to be hard to review patches knowing that new/delete is sometimes
right and sometimes wrong, depending on the type of object it's being called

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list