[Webkit-unassigned] [Bug 19408] Constant folding in parser

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Sep 21 11:40:41 PDT 2008


https://bugs.webkit.org/show_bug.cgi?id=19408





------- Comment #26 from darin at apple.com  2008-09-21 11:40 PDT -------
(From update of attachment 23095)
+        if (v2 != 0)
+            return makeNumberNode(globalPtr, v1 / v2);

Why can't this be done for 0 too? Sure, it would make a NaN node, but is there
a problem with that?

Great test case, but I don't really find the test case easier to read with all
that space padding in it.

What effect does this have on performance? Maybe I'll test it.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list