[Webkit-unassigned] [Bug 20699] SVGPaintServer CleanUp

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Sep 20 15:11:36 PDT 2008


https://bugs.webkit.org/show_bug.cgi?id=20699





------- Comment #15 from zimmermann at kde.org  2008-09-20 15:11 PDT -------
It's a good idea to split up these patches. Several small issues in the one, up
for review:
- DashArray enum declared twice (GraphicsContext.h & SVGPaintServer.h - the
latter should be removed)
- The Qt setLineDash function, could be rewritten to be more readable.

+    unsigned int dashLength = !dashes.isEmpty() ? dashes.size() : 0;
->
+    unsigned int dashLength = dashes.size();


+        unsigned int count = (dashLength % 2) == 0 ? dashLength : dashLength *
2;
->
+        unsigned int count = dashLength;
+        if ((dashLength % 2) != 0)
+            count *= 2;

+        for(unsigned int i = 0; i < count; i++)
->
+        for (unsigned int i = 0; i < count; ++i)

+            pattern.append(dashes[i % dashLength] / (float)pen.widthF());
->
+            pattern.append(dashes[i % dashLength] /
narrowPrecisionToFloat(pen.widthF()));

That's it. Could you upload an updated version?
I'm going to land it then.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list