[Webkit-unassigned] [Bug 20746] Port WebKit to Qt on Windows CE

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 15 14:39:45 PDT 2008


https://bugs.webkit.org/show_bug.cgi?id=20746


eric at webkit.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #23296|review?                     |review-
               Flag|                            |




------- Comment #16 from eric at webkit.org  2008-09-15 14:39 PDT -------
(From update of attachment 23296)
Seems cleaner would be to just have a wrapper function which handled using
errno or not and returned a bool.  We are generally against Macros in WebKit
code (as they make things harder to read and debug).

Here would be an example:

static bool parseLong(const char* string, char*& stopPosition, long maxLength)
{
#if HAVE(ERRNO)
   strtol(string, stopPosition, maxLength);
   return (errno = 0);
#else
  // wince path
#endif
}


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list