[Webkit-unassigned] [Bug 20180] Firefox is faster than webkit on :nth-child tests on SlickSpeed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 11 10:32:46 PDT 2008


darin at apple.com changed:

           What    |Removed                     |Added
  Attachment #23337|review?                     |review+
               Flag|                            |

------- Comment #7 from darin at apple.com  2008-09-11 10:32 PDT -------
(From update of attachment 23337)
This is a great fix!

+    virtual RenderStyle* privateRenderStyle() const;

In other places I've called this sort of function virtualXXX, such as
virtualFirstChild. But also, this function isn't really just a private
renderStyle() function. It's specifically renderStyle() when m_renderer is 0.
I'd suggest a name more like nonRendererRenderStyle().

I'm a little sad that we have to add a whole header just for a single function.
Is there a better name for that header that could allow us to use it for more
things in the future? It's not scalable to have a separate header for each

+    virtual RenderStyle* privateRenderStyle() const { return m_style; }
     String m_value;

I'd like to see a blank line here between the functions and data members.

It's not so great to have these virtual functions defined in the class
definition. There's no reason to inline them.

It's a little strange to have this 10% speedup be a patch on a bug saying
"Firefox is faster". I'd prefer to not have bugs where the titles are are
literally about competitive comparisons, although I think it's great to compare
us with other engines to figure out what we should work on. Does this actually
make WebKit faster than some version of Gecko? Could we retitle the bug or

r=me, but please consider my suggestions

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list