[Webkit-unassigned] [Bug 21816] Clean up ImageBuffer.h so there do not have to be separate ifdefs for each platform
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Oct 28 09:07:49 PDT 2008
https://bugs.webkit.org/show_bug.cgi?id=21816
darin at apple.com changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #24713|review?(darin at apple.com) |review+
Flag| |
------- Comment #17 from darin at apple.com 2008-10-28 09:07 PDT -------
(From update of attachment 24713)
> + success = false; // Make early return mean failure.
If you wanted to match the semantics of your earlier patch you could have done
this at the call site. I think it's fine the way it is, though.
> + ASSERT((reinterpret_cast<size_t>(m_data.m_data) & 2) == 0);
You didn't write this code, but for the record and for else reading this patch,
the correct type to use here is uintptr_t (or intptr_t) rather than size_t. And
also, it's a very strange thing to test. Maybe the person writing it meant to
and with 1 or with 3. I don't understand why it's testing only the 2 bit.
> +#include <QPainter>
> +#include <QPixmap>
> +
> +#include "OwnPtr.h"
We'd normally put these includes into a single paragraph, not two paragraphs.
r=me
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list