[Webkit-unassigned] [Bug 21606] need consistency in naming of collection getters

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 14 18:00:12 PDT 2008


https://bugs.webkit.org/show_bug.cgi?id=21606





------- Comment #1 from ojan at chromium.org  2008-10-14 18:00 PDT -------
from webkit-dev:
It would be great to make things as consistently as possible, though the key
here is "as possible". Some of the IDL interfaces define an explicit
namedItem() or getNamedItem() function, while others have only an implicit name
getter. It is even possible in theory for an interface to have only a method
named namedItem() but no implicit get-by-name behavior.

What I would suggest is to give every class that supports get-by-name a method
called "namedGetter", which is just an inline call to namedItem or getNamedItem
or whatever, if there is an appropriate such method. Then the bindings
generator could be changed so it can make use of that, and not require you to
write namedItem() by hand in the JS bindings (by this I mean the JSC JS
bindings).

Regards,
Maciej


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list