[Webkit-unassigned] [Bug 22214] Keep dead resources in memory cache in purgable memory.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 12 20:50:25 PST 2008


https://bugs.webkit.org/show_bug.cgi?id=22214





------- Comment #4 from mitz at webkit.org  2008-11-12 20:50 PDT -------
(From update of attachment 25114)
> +    static PassRefPtr<SharedBuffer> createWithVolatileBufferTakingOwnership(VolatileBuffer* buffer) { return adoptRef(new SharedBuffer(buffer)); }

I think the usual term for "taking ownership" in WebCore is "adopting". Maybe
this can be called createByAdoptingVolatileBuffer().

> +        // call makeNonVolatile() and check the return value before accessing data

I think you renamed it to tryMakeNonVolatile()

> +#if !PLATFORM(DARWIN) || defined(BUILDING_ON_TIGER)
> +    inline VolatileBuffer* VolatileBuffer::create(const char*, unsigned) { return 0; }
> +    inline VolatileBuffer::~VolatileBuffer() { }
> +    inline const char* VolatileBuffer::data() const { return 0; }
> +    inline void VolatileBuffer::setVolatileCategory(Category) { }
> +    inline bool VolatileBuffer::testPurged() { return false; }
> +    inline bool VolatileBuffer::makeVolatile() { return false; }
> +    inline bool VolatileBuffer::makeNonVolatile() { return false; }
> +#endif

Same above.

> + static const unsigned minVolatileBufferSize = 4096; // one page

Is there a Mach constant or function that returns the page size?


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list