[Webkit-unassigned] [Bug 17133] Should support pausing JavaScript execution without hanging the process

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 14 13:12:44 PDT 2008


http://bugs.webkit.org/show_bug.cgi?id=17133


ggaren at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #19771|                            |review+
               Flag|                            |




------- Comment #39 from ggaren at apple.com  2008-03-14 13:12 PDT -------
(From update of attachment 19771)
I think setPaused / isPaused would be a better naming scheme than
setJavaScriptExecutionAllowed  / javaScriptExecutionAllowed. It matches the
style of setEnabled / isEnabled, it's more terse, and it's more specific about
why JavaScript execution is not allowed, and what will happen to attempts to
execute JavaScript.

+void KJSProxy::setJavaScriptExecutionAllowed(bool allowed)
+{
+    if (!m_globalObject)
+        return;
+

This code seems wrong. It means that a proxy that didn't have a global object
wouldn't "get the memo" about JavaScript being paused, so it might start up JS
execution at a later time.

r=me, with comments


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list