[Webkit-unassigned] [Bug 17811] Widget class refactoring

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Mar 13 09:56:10 PDT 2008


http://bugs.webkit.org/show_bug.cgi?id=17811


darin at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #19724|review?                     |review-
               Flag|                            |




------- Comment #3 from darin at apple.com  2008-03-13 09:56 PDT -------
(From update of attachment 19724)
This won't compile on Mac. There are two implementations of
Widget::frameGeometry.

Having a m_frameRect is wrong for PlatformScrollBarQt and for Mac widgets. And
having that field there, but unused, on those platforms is a recipe for
disaster.

We need to find a different way to share this code.

I'm really sad to see so much use of virtual functions. Our normal
cross-platform strategy is to use compile time #if, not virtual functions.

Changing setParent to take a Widget* is a bad idea. That's going in the wrong
direction. The only kind of parent we support is a FrameView*. We don't need a
general purpose "make any widget a child of any other widget" call.

I didn't get a chance to review this whole thing, but I think we need to do
this refactoring in smaller pieces rather than all at once, and keep all the
platforms working.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list