[Webkit-unassigned] [Bug 17811] New: Widget class refactoring

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Mar 12 14:52:19 PDT 2008


           Summary: Widget class refactoring
           Product: WebKit
           Version: 525+ (Nightly build)
          Platform: PC
        OS/Version: Mac OS X 10.5
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Platform
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: dobey at wayofthemonkey.com

Currently, the Widget class is split up with several #if PLATFORM() statements,
with duplicate code across many platforms, as well as a circular dependency on
the derived class ScrollView. This patch is intended to clean up the circular
dependence and provide shared methods for the many duplicate methods, rather
than copying the code between platforms.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list