[Webkit-unassigned] [Bug 19931] Input should be printed before the output in the console

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 8 07:16:38 PDT 2008


https://bugs.webkit.org/show_bug.cgi?id=19931


aroben at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #22148|review?                     |review-
               Flag|                            |




------- Comment #5 from aroben at apple.com  2008-07-08 07:16 PDT -------
(From update of attachment 22148)
+        Fix for https://bugs.webkit.org/show_bug.cgi?id=19931

We usually include the title of the bug, then the URL, like this:

Fix Bug 19931: Input should be printed before the output in the console

<https://bugs.webkit.org/show_bug.cgi?id=19931>

+        * page/inspector/Console.js: Console command line input gets printed
immediately.

We normally try to describe the actual changes made here, not what the problem
was that inspired the changes. We also try to break up the changes by function,
like this:

(WebInspector.Console.prototype._enterKeyPressed): Split the input/output into
two pieces. The input is added to the console before it is evaluated. After
evaluation the output is added.

+WebInspector.ConsoleCommandResult = function(command, result,
formattedResultElement, level)
+{
+    this.command = command;

I don't think we need to pass in and store the command here.

I think ConsoleCommandInput and ConsoleCommandOutput would be better names fro
these types than ConsoleCommand and ConsoleCommandResult. What do you think?

I guess there's a chance that some styling will change as a result of this, but
it looks like the common cases stay the same.

r- so that the ChangeLog can be fixed up and the new names can be considered.
Looking good!


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list