[Webkit-unassigned] [Bug 12248] Apple-style-span class seems unnecessary

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 29 18:24:26 PST 2008


http://bugs.webkit.org/show_bug.cgi?id=12248





------- Comment #14 from justin.garcia at apple.com  2008-01-29 18:24 PDT -------
I see several complaints here.  Let me try and separate them:

Styled spans don't let the author customize styles, like bold, italic and
underline.  One commenter writes:

> if you have a specific style for bold text on your page there no way you can make a style
> sheet work with output that just sayes <span style="font-wight:bold"> rather
> then <b> or <strong> and it takes up more space.

This should be addressed by <http://bugs.webkit.org/show_bug.cgi?id=13490>
Implement execCommand("styleWithCSS", ...).

WebKit inserts unnecessary spans:

> Right now, webkit inserts so many wrong spans. And if you try to copy paste text 
> inside the editor, so many wrong tags are inserted.

This is not yet filed.

If a custom class on markup created by editing is necessary, it should be
hidden and not appear in output from methods like innerHTML:

> when trying to get the html javascript should only be handed the clean, like
>  wise webkit should automatically generate theas when ever it is feed html 
> in to an edit box. Mozila has tons of tags like this but as it handles things 
> like i just described you don't se it in the output.

This is what the title of this bug report describes, so lets let this bug
report cover this issue.

There are problems with formatting in the Wordpress editor:

> i just walked into the same issues with the tinymce editor (included in wordpress blogs).
> actually this kills your format, so effectively it's not possible to use wordpress with safari(3).

This sounds like <http://bugs.webkit.org/show_bug.cgi?id=14350> WordPress:
Editor strips paragraph breaks,
which is an evangelism issue (and frustratingly still unfixed).  Could those of
you having problems with WordPress verify this?

So that leaves just one issue unfiled: that WebKit inserts unnecessary spans
during some editing operations.  Danny Bloemendaal mentioned this one.  Danny,
could you please file a new bug and provide steps to reproduce?

Let me know if I've left something out here.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list