[Webkit-unassigned] [Bug 17065] New: [GTK] Use a consistent coding style

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 29 07:18:54 PST 2008


           Summary: [GTK] Use a consistent coding style
           Product: WebKit
           Version: 525+ (Nightly build)
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Keywords: Gtk
          Severity: Normal
          Priority: P2
         Component: WebKit Gtk
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: christian at imendio.com

The way sources are formatted is still very inconsistent, regarding naming,
structure and doing the same task in different ways.

This patch attempts to introduce a throughout convention that we can agree upon
for future contributions. Further more by avoiding superfluous typechecks code
becomes more efficient.

Some of the changes are:
1. Defining all gobject types in webkitdefines.h.
2. Using 'priv' as the name of the private structure and using ->priv
throughout the source without a FOO_GET_PRIVATE macro.
3. Renaming WebKitWebFramePrivate->frame to 'coreFrame'.
4. Preferring private members over public api.

There are no api or functional changes.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list