[Webkit-unassigned] [Bug 16979] Patch to conditionalize some CG/Cairo support in win32

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 23 13:07:21 PST 2008


------- Comment #12 from aroben at apple.com  2008-01-23 13:07 PDT -------
(In reply to comment #8)
> By "native", I mean the code that uses Win32 API directly, for example places
> where we use GDI directly. I'm suggesting that WIN can refer to these bits.

That seems OK. "Win32" might be even more explicit, but I'm not sure I prefer

> Many of the *Win source files only use Win32 directly and aren't Apple-specific
> at all, so it makes sense to continue to use Win as an umbrella port name here.
> Files which are mostly Apple-Win should probably be given a new name. I'd
> propose moving SearchPopupMenuWin.cpp to SearchPopupMenuAWin.cpp and creating a
> new SearchPopupMenuWin.cpp that uses native Win32 (Cairo doesn't come into the
> picture here) for now.

Probably SearchPopupMenuCF.cpp is more appropriate (see below).

> My AWin proposal is just to get the debate going, you may have better ideas :-)
> I think it'll become more clear how to elegantly split the code modules as the
> port develops and starts to work.

It seems like we need to have a distinction between configuration options and
ports. I think of configuration options as things like "enable SVG as image
support", "use Cairo for the graphics library", etc. The configuration options
generally map to our preprocessor macros like PLATFORM() and ENABLE(). Ports I
think of as bundles of configuration options, and the configuration options
used for a particular port may change over time.

So, I think that something like an AWin suffix is too port-oriented, when it
should really be configuration-option-based. We already have a lot of
configuration-option-based filenames (*CG.cpp, *Cairo.cpp, etc.), so I think we
should stick with that method.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list