[Webkit-unassigned] [Bug 16924] Shared PluginDatabase, PluginPackage, and PlugInInfoStore Implementations

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jan 20 23:00:57 PST 2008


http://bugs.webkit.org/show_bug.cgi?id=16924





------- Comment #3 from mrowe at apple.com  2008-01-20 23:00 PDT -------
A few things jump out at me.  You've taken two member variables of
PluginPackage and turned them into file-level statics, which seems like a bad
way for passing data between functions.

+static DWORD m_fileVersionLS = 0;
+static DWORD m_fileVersionMS = 0;

You've moved isPluginBlacklisted to a static function rather than a member
function, but it appears to need access to the instance to check name() and
fileName(), and the two file version variables mentioned above.

The new PluginViewWin::createPluginView is not declared correctly in the
header.  It should be declared as static and have the class name omitted.


There's a small change in two places in PluginDatabase that needs some
justification:

     for (PluginSet::const_iterator it = m_plugins.begin(); it != end; ++it) {
         if ((*it)->mimeToDescriptions().contains(key)) {
             plugin = (*it).get();
-            // prefer plugins in our own plugins directory
-            if (plugin->parentDirectory() == ourPath)
-                break;
         }
     }

Why is it ok to remove this?

I'm not sure that it makes sense to put unloadModule in FileSystem.cpp either. 
It doesn't seem to be all that related to the file system.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list