[Webkit-unassigned] [Bug 16618] [GTK] build-webkit and run-webkit-tests autootools support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jan 20 22:43:02 PST 2008


http://bugs.webkit.org/show_bug.cgi?id=16618





------- Comment #5 from mrowe at apple.com  2008-01-20 22:43 PDT -------
This is looking good.  One comment I have is that trying to align code with
whitespace like:

+    push @options, $databaseSupport         ? "--enable-database"           :
"--disable-database";

is messy.  In this instance, I think you could extract the conditional into a
small helper function that generates the argument, so you could use it like:

    push @options, featureFlag($databaseSupport, "database");

(feel free to pick a better name, I didn't think too hard about that one).

It'd be good if you could add the missing space in the following line and
remove the mention of Qt from it while you're touching the code around it:

797 846         die "The Gtk portbuilds JavaScriptCore/WebCore/WebKitQt in one
shot! Only call it for 'WebKit'.\n";


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list