[Webkit-unassigned] [Bug 16924] Shared PluginDatabase, PluginPackage, and PlugInInfoStore Implementations

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 4 14:57:51 PST 2008


------- Comment #13 from darin at apple.com  2008-02-04 14:57 PDT -------
(From update of attachment 18916)
-        if (compareFileVersion(silverlightPluginMinRequiredVersionMS,
silverlightPluginMinRequiredVersionLS) >= 0)
+        if (info->dwFileVersionMS < silverlightPluginMinRequiredVersionMSDWORD
+            (info->dwFileVersionMS ==
silverlightPluginMinRequiredVersionMSDWORD && info->dwFileVersionLS <

You want the new version of this, with the compareFileVersion function. Not the
old version.

This patch makes too many changes at once, making it unnecessarily large, and
making it harder to get review.

I suggest we do the renaming part of this patch first, separately, so we can
more clearly see the changes other than renaming. Lets use the
do-webcore-rename script to do the renaming.

Then a next patch could be to just add the new FileSystem functions.

Then we can see what's left. The patch remaining after taking those steps
should be way smaller.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list