[Webkit-unassigned] [Bug 22352] Annotating opcodes with length

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 8 12:47:17 PST 2008


cwzwarich at uwaterloo.ca changed:

           What    |Removed                     |Added
  Attachment #25261|review?                     |review-
               Flag|                            |

------- Comment #2 from cwzwarich at uwaterloo.ca  2008-12-08 12:47 PDT -------
(From update of attachment 25261)
This is a really great idea. I only see two issues. First, you use an enum to
store the lengths. It would make a lot more sense to use const ints instead. It
would also make more sense to use OPCODE_SIZE instead of GET_OPCODE_SIZE, since
there is no lookup and the value is resolved at compile time. I am r-'ing this,
but I really like the change and it is something we definitely need.

If you don't want to update this patch to ToT WebKit due to all the conflicts,
you can tell me that you want me to do it. Or you can just do the bytecode
interpreter and I can do the JIT, since the JIT code is changing a lot every
day now.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list