[Webkit-unassigned] [Bug 22528] Move currentThreadStackBase() to WTF

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 5 10:06:04 PST 2008


darin at apple.com changed:

           What    |Removed                     |Added
  Attachment #25554|review?                     |review-
               Flag|                            |

------- Comment #5 from darin at apple.com  2008-12-05 10:06 PDT -------
(From update of attachment 25554)
I don't like the word "utilities" in a file name; it seems to be a word without
meaning. I suggest calling this something like MachineStack.h.

If the macro is going to be in a header file, then I think it should be changed
into an inline function that takes a const void*, so we don't have to add a
WTF_ prefix to it.

Why include <stdlib.h>? I think all you need in this header is the type
intptr_t, and that's not in <stdlib.h>.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list