[Webkit-unassigned] [Bug 16814] Give plugin a chance to handle ActiveX objects
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Aug 27 21:33:04 PDT 2008
https://bugs.webkit.org/show_bug.cgi?id=16814
------- Comment #12 from andersca at apple.com 2008-08-27 21:33 PDT -------
(From update of attachment 22688)
>- if (classId.contains("D27CDB6E-AE6D-11cf-96B8-444553540000"))
>+#ifndef DISABLE_ACTIVEX_TYPE_CONVERSION_FLASH
In WebCore we tend to not use #ifndef DISABLE_... Instead, we use the
feature macros from
http://trac.webkit.org/browser/trunk/JavaScriptCore/wtf/Platform.h#L29
I also think that this chain of ifs could perhaps be refactored into a static
HashMap?
>+// To decide whether we should use the embed tag inside the object tag or not.
>+static bool ShouldUseEmbedForObject(HTMLObjectElement* o)
>+{
Like Eric said, this is not how we name methods. How about something like
shouldUseNestedEmbedIfExists (not sure exactly)
> // If we still don't have a type, try to map from a specific CLASSID to a type.
>- if (serviceType.isEmpty() && !o->classId().isEmpty())
>+ // However, if we have the embed tag we shouldn't do so because the outer object
>+ // may be converted to application/x-oleobject, while we are not getting the paramaters
Typo here, should be "parameters".
Overall, I think the patch is definitely a step in the right direction, and I
don't think we need to move it to another file just yet.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list