[Webkit-unassigned] [Bug 20013] Windows AX heuristics are poor
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Aug 26 15:47:19 PDT 2008
https://bugs.webkit.org/show_bug.cgi?id=20013
------- Comment #78 from sankaraditya+bugzilla at gmail.com 2008-08-26 15:47 PDT -------
Jon,
I have checked this code for dynamic webpages also. I have written a simple
webpage that adds and removes a <div> element when a button is pressed. My
changes are working perfectly fine. I will create the layout tests ASAP and
upload them.
I am referencing m_children variable in the new functions that I have created.
So, I need to change the functions i.e addChildren() and children() into const
functions. As a part of this, I need to change the m_children variable into a
mutable object. Otherwise we will face compilation errors.
~ Thanks.
(In reply to comment #64)
> (From update of attachment 22599 [edit])
> + Add functions to navigate properly between the accessibility parent
> + and accessibility children.
>
> I'm not sure that this description gets the point across. The bug is that,
> currently, calling previousSibling, nextSibling, etc on an accessibility object
> could return items that shouldn't be exposed because their accessibility is
> ignored, correct? This should be more explicit in the ChangeLog.
>
> This patch contains the previous patch's changes to children/addChildren. These
> should be removed from this patch.
>
> I'm not sure that this patch will work properly if objects in the DOM are moved
> between parents, or if objects are added or removed. This will need a layout
> tests that confirm that, after these sorts of DOM operations, navigating
> between elements gives the expected result. If you find that the behavior is
> not correct, you might look at how parentObjectUnignored works and follow the
> same method.
>
> I think the name of the new methods should be consistent with the name of the
> parentObjectUnignored method, so the methods should be renamed
> nextSiblingUnignored, previousSiblingUnignored, and so on.
>
> + AccessibilityObject* parentObj = m_object->parentObjectUnignored();
> +
> + if (parentObj) {
> + *parent = static_cast<IDispatch*>(wrapper(parentObj));
> + (*parent)->AddRef();
> + return S_OK;
> + }
> +
> This is a separate bug that could have its own patch.
>
> Thanks, Sankar! r- for these issues.
>
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list