[Webkit-unassigned] [Bug 20343] [CAIRO] half functionality of border-radius

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 22 02:27:50 PDT 2008


https://bugs.webkit.org/show_bug.cgi?id=20343


eric at webkit.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #22724|review?                     |review+
               Flag|                            |




------- Comment #2 from eric at webkit.org  2008-08-22 02:27 PDT -------
(From update of attachment 22724)
I'm not sure I 100% understand the code, but it looks sane enough.

falen really could have a better variable name.  "fa" too.

It seems sad there is not a slicker way to handle this:
+    if (w != h)
+        cairo_scale(cr, 1., scaleFactor);
+    
+    cairo_arc_negative(cr, x + hRadius, (y + vRadius) * reverseScaleFactor,
hRadius, -fa * M_PI/180, -falen * M_PI/180);
+
+    if (w != h)
+        cairo_scale(cr, 1., reverseScaleFactor);
+

w/o setting and un-setting the scale factor.


-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list