[Webkit-unassigned] [Bug 20446] New: rename NPCocoaEvent's "event" struct to "data"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 19 11:21:29 PDT 2008


           Summary: rename NPCocoaEvent's "event" struct to "data"
           Product: WebKit
           Version: 526+ (Nightly build)
          Platform: Macintosh
               URL: https://wiki.mozilla.org/Mac:NPAPI_Event_Models
        OS/Version: Mac OS X 10.5
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: Plug-ins
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: joshmoz at gmail.com
                CC: andersca at apple.com

We should rename NPCocoaEvent's "event" structure to "data" to avoid things
like "event->event.draw.x" and "event.event.draw.x". People tend to name the
NPCocoaEvent "event" and it doesn't read well. This happens often in WebKit's
impl and it'll happen all over plugin code written for the Cocoa event model.

We'd change the spec here:


Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list