[Webkit-unassigned] [Bug 18539] multipart/form-data not being parsed correctly on server due to '+' in boundary string

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 16 17:22:35 PDT 2008


------- Comment #4 from hoicem at googlemail.com  2008-04-16 17:22 PDT -------
(In reply to comment #3)
> (In reply to comment #2)
> > I'm informed by JMBSoft that's it's "pure Perl using all custom in-house code".
> > Would it help if I tried to get the code that handles the form when submitted?
> Are they using CGI.pm to do the form parsing, or something else?  You should
> point them at this bug to see if they can reproduce the issue on their own and
> fix it.
> Note that Safari for Windows should behave the same as Safari for Mac OS X.

I've asked for the source.

Having them try and fix anything isn't going to happen because this script is
an old version and I get the impression. It just happens to be used by lots of
sites which my webkit app needs to submit to. Also, I would assume that they'll
be other forms that may use a similar method/script.

All worked fine prior to Safari 3 so what changed in Safari 3? 

I just tested on windows platform Safari 3. At first I thought the bug wasn't
present as I submitted about 50 times and got success every time. However, I
eventually did get the error message but this only seemed to happen when I
click back and submitted really quickly.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list