[Webkit-unassigned] [Bug 15334] Split ResourceResponse into platform specific files

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 17 14:17:00 PDT 2007


http://bugs.webkit.org/show_bug.cgi?id=15334


julien.chaffraix at gmail.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #16487|0                           |1
        is obsolete|                            |
  Attachment #16707|                            |review?
               Flag|                            |




------- Comment #7 from julien.chaffraix at gmail.com  2007-10-17 14:16 PDT -------
Created an attachment (id=16707)
 --> (http://bugs.webkit.org/attachment.cgi?id=16707&action=view)
Patch updated with Darin's comment

The new patch has been generated with "svn move" and "svn-create-patch". Thanks
for the tip.

Again the patch has been tested only on linux.

>+
>const_cast<ResourceResponse&>(asResourceResponse()).doUpdateResourceResponse();

> Why use const_cast here? Could we instead make the relevant members all be
> mutable?

After a quick look at the code, adding mutable to the members of 
ResourceResponseBase would leave only one member non-mutable so I do not think
that is worth it.

I agree that the 2 casts are not really beautiful. I have tried a lot of
alternatives and the conclusion is that we need the 2 casts.

> I'm always uncomfortable with the "do" prefix in cases like this.
> Perhaps we could come up with a more descriptive name for the function that
> does the actual work.

I could not find a better name. Maybe someone has a better idea.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list