[Webkit-unassigned] [Bug 14998] Full page zooming support
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sun Oct 7 16:15:05 PDT 2007
http://bugs.webkit.org/show_bug.cgi?id=14998
aroben at apple.com changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #16529|review? |review-
Flag| |
------- Comment #27 from aroben at apple.com 2007-10-07 16:15 PDT -------
(From update of attachment 16529)
- IntPoint translatePoint(const IntPoint&) const;
+ IntRect translateRect(const IntRect&) const;
I don't think translateRect is a good name for this method, since it both
translates and scales. A better name might be transformRect.
+ WebKitPage* page = WEBKIT_PAGE(containingWindow());
+ WebKitPagePrivate* pageData = WEBKIT_PAGE_GET_PRIVATE(page);
This code (in ScrollViewGtk.cpp) is unused. We also should not be using WebKit
types within WebCore.
+ double scaleFactor = frameView->frame()->page()->scaleFactor();
There are a number of places where the result of Frame::page() is being used
without a null-check. This is in general an unsafe thing to do.
r- given the above and Darin's comments. I think Darin gave some really good
suggestions about how to improve the design of this feature.
--
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list