[Webkit-unassigned] [Bug 15691] [GTK] Public API does not follow GTK+ conventions

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 30 16:56:21 PST 2007


------- Comment #21 from christian at twotoasts.de  2007-11-30 16:56 PDT -------
(In reply to comment #20)
> Actually if you are ultra-pedantic, the underscores separate words, not
> capitalization. So webkit_* is correct because WebKit is used as one word that
> happens to have funny capitalization.

Little things like that can easily cause confusion. I am not just being
pedantic here. We don't want users to compain and answer "oh, this just happens
to be a bad idea", do we? ;)

I think Webkit* would be an option. If we intentionally want to keep errorneous
capitalization it must be clearly documented.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list