[Webkit-unassigned] [Bug 15984] Implement "navigation-requested" signal for WebKit Gtk

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 21 09:27:03 PST 2007


http://bugs.webkit.org/show_bug.cgi?id=15984





------- Comment #6 from alp at atoker.com  2007-11-21 09:27 PDT -------
(From update of attachment 17432)
>diff --git a/WebKit/gtk/Api/webkitgtkpage.h b/WebKit/gtk/Api/webkitgtkpage.h
>index 23215b4..920ca7c 100644
>--- a/WebKit/gtk/Api/webkitgtkpage.h
>+++ b/WebKit/gtk/Api/webkitgtkpage.h
>@@ -48,7 +48,7 @@ typedef enum {
>     WEBKIT_ACCEPT_NAVIGATION_REQUEST,
>     WEBKIT_IGNORE_NAVIGATION_REQUEST,
>     WEBKIT_DOWNLOAD_NAVIGATION_REQUEST
>-} WEBKIT_NAVIGATION_REQUEST_RESPONSE;
>+} WebKitNavigationRequestResponse;

typedef enum {
     WEBKIT_NAVIGATION_RESPONSE_ACCEPT,
     WEBKIT_NAVIGATION_RESPONSE_IGNORE,
     WEBKIT_NAVIGATION_RESPONSE_DOWNLOAD
} WebKitNavigationResponse;

My suggestion looks more conventional. "RequestResponse" sounds redundant, and
I wasn't too sure about naming of the enum members. What do you think of this
change?

Looks good otherwise.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list