[Webkit-unassigned] [Bug 16053] prepend git branch with build-webkit and friends

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 20 09:31:43 PST 2007


http://bugs.webkit.org/show_bug.cgi?id=16053


ddkilzer at webkit.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #17413|review?                     |review+
               Flag|                            |




------- Comment #6 from ddkilzer at webkit.org  2007-11-20 09:31 PDT -------
(From update of attachment 17413)
>+    unless (defined $gitBranch) {
>+        chomp($gitBranch = `git symbolic-ref -q HEAD`);
>+        $gitBranch =~ s#^refs/heads/##;
>+        $gitBranch = "" if $gitBranch eq "master";
>+        $gitBranch = "" if exitStatus($?);
>+    }

I think it would make more sense to check the exit status immediately after the
command is run.

>branch.$branch.webkitbranchbuild
>core.webkitbranchbuild

Do you have a preference between "webkitbranchbuild" or "webKitBranchBuild" (or
"webkitBranchBuild")?  I see both all-lowercase and camelCase config options in
"man git-config", but I think it's much easier to read the camelCase version.

r=me, although I'd like to see the above changes made when committing.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list