[Webkit-unassigned] [Bug 15993] New: PCRE needs a bath
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Nov 14 16:12:49 PST 2007
http://bugs.webkit.org/show_bug.cgi?id=15993
Summary: PCRE needs a bath
Product: WebKit
Version: 525+ (Nightly build)
Platform: Macintosh
OS/Version: Mac OS X 10.4
Status: NEW
Severity: Normal
Priority: P2
Component: JavaScriptCore
AssignedTo: webkit-unassigned at lists.webkit.org
ReportedBy: eric at webkit.org
CC: darin at apple.com
PCRE needs a bath
Wow. Talk about hard to read code.
Anyway, in attempting to understand what jsRegExpCompile was doing, I ended up
abstracting out the pattern length calculation and giving the entire method a
bath.
All I did here was move out the length calculating code (along with associated
local variables), move all variable declarations from the start of the block to
where they are used (now that this is c++ and we can!), fix a few minor cases
where the style disagreed with WebKit style (single line ifs, for example,
where { goes, etc.) I'm *certain* I did not catch all style violations. :)
There are *no* functional changes in this patch. It passes all the tests.
--
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list