[Webkit-unassigned] [Bug 15938] New: Inspector/Qt requires patch to SecurityOrigin

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Nov 10 17:35:54 PST 2007


http://bugs.webkit.org/show_bug.cgi?id=15938

           Summary: Inspector/Qt requires patch to SecurityOrigin
           Product: WebKit
           Version: 525+ (Nightly build)
          Platform: Macintosh
        OS/Version: Mac OS X 10.4
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: New Bugs
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: freyther at handhelds.org


On the Qt port the Inspector will be embedded into the binary using QResources
(qrc). The embedded files can be accessed using the qrc protocol.
The issue is that the Inspector JavaScript requires certain priviliges to
function properly. This is where isSafeScript and SecurityOrigin are involved.
For the mac/win port the inspector.html is found inside the bundle and can be
accessed using the file protocol. So SecurityOrigin grants the needed
priviliges when using 'file' but not when using 'qrc'. One solution would be to
use FrameLoader::canTreatAsLocalURL in SecurityOrigin::canAccess.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list