[Webkit-unassigned] [Bug 13478] RenderObject::absoluteBoundingBoxRect() should ignore rects outside the bounds of the document

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 2 10:06:38 PDT 2007


http://bugs.webkit.org/show_bug.cgi?id=13478


ddkilzer at webkit.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #14219|0                           |1
        is obsolete|                            |
  Attachment #14310|                            |review?
               Flag|                            |




------- Comment #12 from ddkilzer at webkit.org  2007-05-02 10:06 PDT -------
Created an attachment (id=14310)
 --> (http://bugs.webkit.org/attachment.cgi?id=14310&action=view)
Patch v4

Addressing issues in Comment #10:
- Updated all absoluteRects() methods to clip rects added to document bounds.
- Added Document::bounds() method to return a rect with coordinates (0,0) and
the height/width set to the contents.
- Added RenderObject::addRectClippedToBounds() method to avoid code
duplication.

Questions:
- Is Document the correct place to put the bounds() method?  I thought about
putting it on the FrameView instead, but wanted to avoid calling
document()->view()->bounds() instead of just document()->bounds().
- Is bounds() a good name for Document::bounds()?  Others:  boundsRect(),
contentsRect(), contents()?
- Is addRectClippedToBounds() a good name?  Should it be more generic?  Is
there other code that could be using this method?
- Does the way WebCoreAXObject.mm uses absoluteRects() cause this patch to
prevent users with special needs from accessing elements on the page, or does
it only deal with the visible (rendered) part of the page and we're only
clipping non-visible content anyway?


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list