[Webkit-unassigned] [Bug 14757] REGRESSION: HTMLTokenizer::processingData implementation is incorrect

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 31 13:16:44 PDT 2007


darin at apple.com changed:

           What    |Removed                     |Added
  Attachment #15763|review?                     |review+
               Flag|                            |

------- Comment #20 from darin at apple.com  2007-07-31 13:16 PDT -------
(From update of attachment 15763)
+    if (m_frame->page())
+        checkLoadComplete();

The checkLoadComplete() function checks to see if the page is 0 -- why do we
need an additional check in the caller? Is the problem with the assertion? If
so, maybe we should move the assertion inside the if statement.

+    if (m_frame->page()) {
+        if (asynchronous)
+            scheduleCheckLoadComplete();
+        else
+            checkLoadComplete();
+    }

Also seems unnecessary to check for page of 0 here.

I don't understand the meaning of the "asynchronous" parameter in
stopForUserCancel. The stop itself seems to be immediate no matter what, so the
only that's deferred is the "check load complete". Given that, I think the
parameter name is quite unclear.

Otherwise looks, good, and these are really nitpicks, so r=me.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list