[Webkit-unassigned] [Bug 14806] [gtk] [patch] Implement can_go_backward and can_go_forward in webkitgtkpage.cpp

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jul 29 14:31:03 PDT 2007


aroben at apple.com changed:

           What    |Removed                     |Added
  Attachment #15726|                            |review-
               Flag|                            |

------- Comment #2 from aroben at apple.com  2007-07-29 14:31 PDT -------
(From update of attachment 15726)
The implementation looks good. Just a few comments to bring this patch in line
with <http://webkit.org/coding/coding-style.html>

+gboolean webkit_gtk_page_can_go_backward (WebKitGtkPage* page)

There should be an empty line before/after all functions. Please remove the
space before the open parenthesis.

+    WebKitGtkPagePrivate* page_data = WEBKIT_GTK_PAGE_GET_PRIVATE(page);
+    WebKitGtkFramePrivate* frame_data =

After talking with Holger, I think we're going to move towards maintaining the
WebKit camelCase style for variable names within the WebKit/gtk implementation
files. So these variables should be called pageData and frameData. I know it's
inconsistent with the rest of the file, but that will be cleaned up later.

You also need a ChangeLog entry to go along with your patch. See
<http://webkit.org/coding/contributing.html> for instructions on how to
generate one.

Once these are addressed, I think we can get this landed!

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list