[Webkit-unassigned] [Bug 14626] Make bidiReorderCharacters independent of RenderBlock

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jul 15 16:37:28 PDT 2007


http://bugs.webkit.org/show_bug.cgi?id=14626





------- Comment #1 from mitz at webkit.org  2007-07-15 16:37 PDT -------
Created an attachment (id=15526)
 --> (http://bugs.webkit.org/attachment.cgi?id=15526&action=view)
[WIP] Move the bidi algorithm implementation into a static function

This patch turns the RenderBlock member function bidiReorderLine() into a thin
wrapper around a new static function, createBidiRunsForLine() whose arguments
are start and end bidi iterators and a BidiState. Thus the static function
doesn't deal with renderers and render style. The patch also makes the bidi
context part of the bidi state.

The next step should be to allow the bidi iterators to be interchanged with
iterators that do not have an underlying render tree. I think that might prove
tricky to do without hurting performance.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list