[Webkit-unassigned] [Bug 14497] New: [GDK] Rename "gdk" port to "gtk"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 2 10:57:35 PDT 2007


           Summary: [GDK] Rename "gdk" port to "gtk"
           Product: WebKit
           Version: 522+ (nightly)
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: New Bugs
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: alp at atoker.com

The "gdk" naming convention is a historical quirk that we should fix now that
this is clearly a GTK+ port. This does not preclude the possibility of a
gdk-only port if someone wants to pick up work on that project again, as it can
be done under the umbrella of the GTK+ port.

The renaming can be done in a few steps:

Update the build files
Rename 'gdk' directories
Rename files named FooGdk.(cpp|h)
Rename classes named like FooGdk

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list