[Webkit-unassigned] [Bug 12852] Drosera should select function name, not "function" keyword when selecting from function list pop-up

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 21 23:52:46 PST 2007


vladimir.olexa at gmail.com changed:

           What    |Removed                     |Added
  Attachment #13310|                            |review?
               Flag|                            |

------- Comment #1 from vladimir.olexa at gmail.com  2007-02-21 23:52 PDT -------
Created an attachment (id=13310)
 --> (http://bugs.webkit.org/attachment.cgi?id=13310&action=view)

Since Xcode doesn't handle a situation like object = function(), we still pick
up the name before the assignment operator. Therefore, when a function is
formatted properly, e.g. function foo(), we select "foo" like Xcode. However,
if the function is anonymous, we select the "function" keyword, just to handle
this case as well. 

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list