[Webkit-unassigned] [Bug 12160] Linux/Gdk build fixes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 7 10:09:26 PST 2007


http://bugs.webkit.org/show_bug.cgi?id=12160


aroben at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #12991|review?                     |review+
               Flag|                            |




------- Comment #20 from aroben at apple.com  2007-02-07 10:09 PDT -------
(From update of attachment 12991)
+#include <cairo.h>
 #include "FloatRect.h"
 #include "Font.h"
+#include "FontData.h"
 #include "IntRect.h"
-#include <cairo.h>
 #include <math.h>
+#include <stdio.h>

   cairo.h should stay where it was, above math.h.

-void GraphicsContext::setFocusRingClip(const IntRect&)
+void GraphicsContext::setFocusRingClip(const IntRect& rect)

   This change is unnecessary.

+void GraphicsContext::setPlatformFillColor(const Color& col)
+{
+    setColor(m_data->context, col);
+    cairo_fill(m_data->context);

   Does cairo_fill actually do a fill? That's not what we want here, we just
want to set a color for when a fill does happen later. Ditto for stroke.

+    if (m_decoder) {
+        delete  m_decoder;
+        m_decoder = 0;

   Null check is unnecessary. There's an extra space after 'delete'.

+    BitmapImage* img = new BitmapImage();

   Parentheses are unnecessary here.

   If cairo_stroke and cairo_fill don't actually do a stroke/fill, r=me.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list