[Webkit-unassigned] [Bug 16222] [GTK] Implement inline search and highlighting of matching strings.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Dec 2 10:03:26 PST 2007


http://bugs.webkit.org/show_bug.cgi?id=16222


aroben at apple.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #17650|review?                     |review-
               Flag|                            |




------- Comment #6 from aroben at apple.com  2007-12-02 10:03 PDT -------
(From update of attachment 17650)
 207 static Frame *incrementFrame(Frame *curr, bool forward, bool wrapFlag)

The *s are misplaced here -- they should go next to the type.

 214 bool Page::findString(const String& target, bool forward, bool caseFlag,
bool wrapFlag)

I think caseFlag should be called caseSensitive and wrapFlag should be called
wrap or shouldWrap.

 244 uint Page::markAllMatchesForText(const String& target, bool caseSensitive,
bool highlight, uint limit)

You should use unsigned instead of uint.

 249     uint matches = 0;

Ditto.

 102         bool findString(const String&, bool, bool, bool);

Can this method be const?

It would be nice to change some of the do-while loops into for loops, but
that's optional for this patch.

r- to fix these issues, then let's get this in! Thanks for putting this down in
WebCore.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list