[Webkit-unassigned] [Bug 15100] XMLHttpRequest::urlMatchesDocumentDomain raises error if port information does not match exactly

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 28 21:21:59 PDT 2007


http://bugs.webkit.org/show_bug.cgi?id=15100





------- Comment #12 from sam at webkit.org  2007-08-28 21:21 PDT -------
A few comments on this itteration,

Please capitalize the first word in the comment.
+    // make sure that the default http / https port 80 / 443 is used for
comparison

Our style dictates that these variables should be named documentPort and
urlPort.
+    int document_port = documentURL.port();
+    int url_port = url.port();

Please put a space after the if.  This goes for a few other places as well.  In
addition, a slightly better way to do this comparison is to use the
equalIgnoringCase(stringA, stringB) function.
+        if(documentURL.protocol().lower() == "http")

If we make this change, we definitely need to make it in the isSafeScript check
as well.


-- 
Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.



More information about the webkit-unassigned mailing list