[Webkit-unassigned] [Bug 15003] The "constructor" property on Function.prototype should not be DontDelete/ReadOnly

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Aug 19 08:53:04 PDT 2007


ddkilzer at webkit.org changed:

           What    |Removed                     |Added
                 CC|                            |sam at webkit.org,
                   |                            |ddkilzer at webkit.org
             Status|UNCONFIRMED                 |NEW
     Ever Confirmed|0                           |1

------- Comment #1 from ddkilzer at webkit.org  2007-08-19 08:53 PDT -------
I believe there may be similar changes required in JavaScriptCore/kjs/nodes.cpp
for FuncDeclNode::processFuncDecl(ExecState*) and
FuncExprNode::evaluate(ExecState*) if this does indeed fix the bug.  (I think
the duplicate code should be refactored into its own method as well!)

This bug reminded me of revision r19203:

Test case confirmed with a local debug build of WebKit r25142 with Safari 3
Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).

Both Opera 9.22 and Firefox pass the given test.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list