[Webkit-unassigned] [Bug 13352] New: [Regression] Gmail hangs on send message

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Apr 15 00:32:11 PDT 2007


           Summary: [Regression] Gmail hangs on send message
           Product: WebKit
           Version: 522+ (nightly)
          Platform: Macintosh
               URL: http://mail.google.com
        OS/Version: Mac OS X 10.4
            Status: UNCONFIRMED
          Severity: Blocker
          Priority: P2
         Component: Page Loading
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: ruben at mailplaneapp.com

When I send a Gmail message by pressing the "Send" button, the message is not
delivered and the status message (right upper corner) stays on "Sending...". A
second click can resolve the problem. However, this is unusable, as there may
be a big upload (file attachments) going on. This does not happen always, but
often: maybe about one out of ten to 20 times. 
See attached screenshots (gmail and activity window) for how it looks like for
the user. 
The problem cannot be reproduced with Webkit 419.3. 

Steps to reproduce:
1) start Webkit.app
2) goto mail.google.com and log in.
3) click the link "compose message"
4) fill "To", "Subject" and message text
5) click the "Send" button
6) goto 3) until you see the infinite "Sending..." status message

I did some analyzing, and I have tried to find out why it is happening:

Console log:
I have started a debugger in the WebCore project. There are not errors shown in
the console log. 

In my application I have registered a FrameLoadDelegate. When the faulty send
happens, the delegate gets called with webView:didStartProvisionalLoadForFrame:
but never with the webView:didCommitLoadForFrame:,
webView:didFailProvisionalLoadWithError:forFrame:frame or

I have traced the network traffic with "ethereal". When you send a Gmail
message Webkit sends a POST and then waits for a response. The POST is always
sent, but there is no Google response when the problem happens. I have attached
this ethereal information always for the OK and PROBLEM case: Screenshots of
network traffic, text file of POST, and the original ethereal files.

Spoofing as FF:
I tried spoofing as Firefox to rule out a problem on the Google servers. It was
more difficult to reproduce the problem, but it still happened.

It seems to happen more often just before, during, or just after a Gmail

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list