[Webkit-unassigned] [Bug 13328] Code cleanup in image pasteboard code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 11 09:37:27 PDT 2007


------- Comment #2 from darin at apple.com  2007-04-11 09:37 PDT -------
(From update of attachment 14007)
+    if (frame->document() && frame->document()->isImageDocument()) {
+        Document* doc = frame->document();

If you're going to have a local variable here, then I suggest declaring it
outside the if statement.

Further, I think this function would read better with early exits and a couple
more local variables.

It also might be good to make the function return the image element instead of
a boolean, allowing us to share slightly more code.

Otherwise looks great. I'm not going to say review+ right now, but I'll
probably look back later today.

Configure bugmail: http://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the webkit-unassigned mailing list