[Webkit-unassigned] [Bug 10696] RenderPathQuartz and RenderPathQt should not be needed
bugzilla-daemon at opendarwin.org
bugzilla-daemon at opendarwin.org
Sun Sep 3 00:11:55 PDT 2006
http://bugzilla.opendarwin.org/show_bug.cgi?id=10696
macdome at opendarwin.org changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #10371|review? |review-
Flag| |
------- Comment #2 from macdome at opendarwin.org 2006-09-03 00:11 PDT -------
(From update of attachment 10371)
Unfortunately I lost all my good comments due to a Safari crash. Here is an
abridged version:
1. Lots of style nits. Pointers in the "wrong" place, missing spaces between
ifs, {} misplaced. While we're moving this code around we should fix the
style.
2. if/elseif/else sets for enums are used where switches should be. Also some
enum-based switches here use default: instead of mentioning each enum value.
Using a switch statement for an enum and mentioning each enum value by name is
best as it allows for better compile-time error checking.
3. DrawMarkersData should use constructor-style initializers here:
+ elementIndex = 0;
+ midMarker = mid;
(yes, I know this is old code copied, but might as well fix it now.)
4. createRoundedRectangle needs a bath:
+ double nrx = rx, nry = ry;
should be renamed (I have no clue what nrx is...)
0.552 should be turned into a nicely named constant (to make its use more
understandable.
Not needed:
+ // Ellipse creation - nice & clean agg2 code
+void CGPathTransformer(void *info, const CGPathElement *element)
is completely unnecessary. Use CGAddPath instead and pass a transform.
Lots of small stuff, but enough to add up to a r-.
--
Configure bugmail: http://bugzilla.opendarwin.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
More information about the webkit-unassigned
mailing list